USA Funds System Requirements

Internet Browsers Supported

  • Internet Explorer 7.0 and higher.
  • Mozilla Firefox 3.6 and higher.
  • Apple Safari 4.0 and higher.
  • Google Chrome 19.0 and higher.

Security Setting
Browser security settings must be set to the “default setting” to ensure the application runs smoothly. If the security settings are not set to the “default,” go to the browser security settings and enable the option for “active scripting” or “scripting of java applets.”